DITA-OT 1.5 and Java version

by

I’ve been doing some work with the DITA Open Toolkit 1.5 lately, and got no love from Google on this issue, so here’s my contribution to anyone else who finds it:

If you are trying to build and get an error like:

DITA-OT1.5/build_preprocess.xml:80: java.lang.StringIndexOutOfBoundsException

Then check the version of your Java. I got this error with Java 1.5, and resolved it by switching to Java 1.6.

I’ll have something more to post about DITA soon, but I just thought I’d get that out there for anyone else who is scouring Google in vain.

Advertisements

3 Responses to “DITA-OT 1.5 and Java version”

  1. Tweets that mention DITA-OT 1.5 and Java version « Professional Open Source Documentation -- Topsy.com Says:

    […] This post was mentioned on Twitter by Jared Morgan and Planet Fedora, FOSS Docs. FOSS Docs said: New Post: DITA-OT 1.5 and Java version: I’ve been doing some work with the DITA Open Toolkit 1.5 lately, and got n… http://bit.ly/cd0Wtd […]

  2. j1mc Says:

    Do you think you’ll be integrating DITA / DITA-OT support into Publican? Currently, the only distro to package both of these is openSUSE, but I’ve been doing some initial work to package them for Fedora. I am new to packaging, though.

    If you intend to do any work on packaging DITA for Fedora, you may find it helpful to check out the specfiles for openSUSE’s RPM’s.

  3. jmswisher Says:

    Do you know about the DITA-users list? That’s where all the DITA and DiTA-OT gurus hang out.
    http://tech.groups.yahoo.com/group/dita-users/

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: